Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57214RabbitMQ: Stored XSS in RabbitMQ management UI

High 7.1

In plain English

A high-severity cross-site scripting in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.2%top 87.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 4.2.5, the RabbitMQ management UI renders the x-internal-purpose queue or exchange argument into an HTML title attribute without proper escaping on the Queues and Exchanges pages, allowing a user with permission to declare a queue or exchange to execute JavaScript in another user's browser. This issue is fixed in version 4.2.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57214
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57214
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57214
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57214
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57214

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.5

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

References