Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M

CVE-2026-57212RabbitMQ management HTTP API accepts request bodies larger than configured max_http_body_size

High 7.1

In plain English

A high-severity resource allocation without limits in rabbitmq-server from rabbitmq. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.4%top 62.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

RabbitMQ is a messaging and streaming broker. Prior to 3.13.14, 4.0.19, 4.1.10, and 4.2.5, the rabbitmq_management HTTP API accepts oversized valid JSON bodies on with_decode and direct_request paths because read_complete_body checks the accumulated size before the final chunk but not the final combined size. This issue is fixed in versions 3.13.14, 4.0.19, 4.1.10, and 4.2.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12rabbitmq-serverno fix listedDEBIAN-CVE-2026-57212
Debian:13rabbitmq-serverno fix listedDEBIAN-CVE-2026-57212
Debian:14rabbitmq-server4.3.0-2DEBIAN-CVE-2026-57212
Ubuntu:22.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57212
Ubuntu:24.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57212
Ubuntu:26.04:LTSrabbitmq-serverno fix listedUBUNTU-CVE-2026-57212
Ubuntu:26.10rabbitmq-serverno fix listedUBUNTU-CVE-2026-57212

Affected products (as reported)

VendorProductVersions
rabbitmq rabbitmq-server >= 4.2.0, < 4.2.5>= 4.1.0, < 4.1.10>= 4.0.0, < 4.0.19>= 3.13.0, < 3.13.14

Weakness: CWE-770 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:L

References