Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-57203Asterisk: Local privilege escalation through ast_loggrabber's world-writable helper location

Medium 6.9

In plain English

A medium-severity security flaw in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.1%top 96.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, `ast_loggrabber` executes a `Python script` from the world-writable `/tmp` directory. An attacker already authorized to open a shell session on the Asterisk server may place a malicious script there and gain elevated privileges or execute code when an administrator runs `ast_loggrabber` as a user with elevated privileges. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57203
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57203
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57203
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57203
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57203

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 20.20.1>= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk < 20.7-cert11>= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-426 · Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N

References