Vulnerability · Published Oct 26, 2026 · Assigned by GitHub_M

CVE-2026-57196Asterisk: Reflected XSS in Phone Provisioning HTTP Error Pages

Low 2.3

In plain English

A low-severity cross-site scripting in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)2.3Low
Exploit odds (30 days)0.8%top 44.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an unauthenticated attacker may use reflected cross-site scripting in `phone provisioning HTTP error pages` to retrieve an authorized user's `AMI session cookie` and impersonate that user when `res_phoneprov` is enabled. The Asterisk HTTP web server, Asterisk Manager Interface (AMI), and AMI access via HTTP must all be enabled; each is disabled by default. The attacker must be able to connect to the HTTP server, which binds only to `127.0.0.1` by default even when enabled, and must convince the authorized user to click a malicious link. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57196
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57196
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57196
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57196
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57196

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 20.20.1>= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk < 20.7-cert11>= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

References