Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-57188Asterisk: Stack buffer overflow in res_xmpp XMPP namespace prefix handling

High 7.1

In plain English

A high-severity out-of-bounds write in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.5%top 55.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may cause a stack buffer overflow in `res_xmpp` `XMPP namespace prefix` handling using carefully crafted packets. The `res_xmpp` module must be loaded, an XMPP connection must be configured in `xmpp.conf`, and the attacker must have an XMPP account on the same or a federated server. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57188
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57188
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57188
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57188
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57188

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 20.20.1>= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk < 20.7-cert11>= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-787 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References