Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-57186Asterisk: CVE-2022-37325 fix is absent from current chan_ooh323 Q.931 party-number parser

High 7.5

In plain English

A high-severity security flaw in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 49% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.6%top 51.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. From 21.0.0-pre1 until Asterisk 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3, the `chan_ooh323` `Q.931 party-number parser` lacks the `CVE-2022-37325` fix because that fix was never forward-ported from Asterisk 20 to later versions. Malformed Q.931 elements in an `OOH323 request` can therefore crash Asterisk. This issue affects Asterisk versions greater than 20. The `chan_ooh323` addon channel driver must be explicitly compiled and installed, which is not the default, and its port must be publicly reachable. This issue is fixed in Asterisk 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57186
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57186
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57186
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57186
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57186

Affected products (as reported)

VendorProductVersions
asterisk asterisk >= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk >= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-839 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References