Vulnerability · Published Oct 27, 2026 · Assigned by GitHub_M

CVE-2026-57185Asterisk: Buffer over-read in Asterisk PJSIP MWI body parser

Medium 6.5

In plain English

A medium-severity security flaw in asterisk from asterisk. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.5%top 58.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Asterisk is an open source private branch exchange and telephony toolkit. Prior to Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3, an authenticated attacker may crash Asterisk through a buffer over-read in the `PJSIP MWI body parser` by sending a carefully crafted `SIP NOTIFY` request. The attacker must pass SIP authentication using either a username/password or `source IP address matching`. This issue is fixed in Asterisk 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk 20.7-cert11, 22.8-cert3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:14asterisk1:22.10.1+dfsg+~cs6.17.60671434-1DEBIAN-CVE-2026-57185
Ubuntu:22.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57185
Ubuntu:24.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57185
Ubuntu:26.04:LTSasteriskno fix listedUBUNTU-CVE-2026-57185
Ubuntu:26.10asteriskno fix listedUBUNTU-CVE-2026-57185

Affected products (as reported)

VendorProductVersions
asterisk asterisk < 20.20.1>= 21.0.0-pre1, < 21.12.3>= 22.0.0-pre1, < 22.10.1>= 23.0.0-pre1, < 23.4.1
asterisk certified-asterisk < 20.7-cert11>= 22.8-cert1-pre1, < 22.8-cert3

Weakness: CWE-126, CWE-170 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References