Vulnerability · Published Oct 28, 2026 · Assigned by GitHub_M
CVE-2026-56828Shopper: read-only team permissions allow administrator creation and permission escalation
High 8.8
In plain English
A high-severity missing authorization in shopper from shopperlabs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Shopper is a Headless e-commerce Admin Panel. From 2.8.0 until 2.8.1, three Shopper Livewire admin components retain authorization gaps after the earlier team-settings authorization fix. A staff member with only `view_users` and `access_dashboard` can mutate permissions, create an administrator, or delete roles. In `packages/admin/src/Livewire/Components/Settings/Team/Permissions.php`, `togglePermission` and `removePermission` authorize `view_users` rather than the stronger `access_setting` permission; `packages/admin/resources/views/livewire/components/settings/team/permissions.blade.php` exposes permission IDs in `wire:click` handlers. The attacker can grant arbitrary permissions to the bound role, including `access_setting` on the attacker's own role, or delete permission definitions. In `packages/admin/src/Livewire/SlideOvers/CreateTeamMember.php`, `mount()` and `store()` also accept `view_users`, and the client-selected `role_id` can identify the admin role, allowing creation of a pre-verified administrator with an attacker-chosen password. In `packages/admin/src/Livewire/Pages/Settings/Team/RolePermission.php`, `deleteAction` has no action authorization and is only conditioned on `can_be_removed`, while page access requires `view_users`. Deleting a removable role removes access for assigned users, enabling RBAC denial of service as well as privilege escalation. This issue is fixed in version 2.8.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | shopper/framework | 2.9.2 | GHSA-j328-xmgp-j4q3 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| shopperlabs | shopper | >= 2.8.0, < 2.8.1 |
Weakness: CWE-285, CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/shopperlabs/shopper/security/advisories/GHSA-j328-xmgp-j4q3 x_refsource_CONFIRM
- https://github.com/shopperlabs/shopper/pull/514 x_refsource_MISC
- https://github.com/shopperlabs/shopper/commit/ac9a76044a8e4a2b570b438d66cf3007f3dc479e x_refsource_MISC
- https://github.com/shopperlabs/shopper/compare/v2.8.1...v2.9.2 x_refsource_MISC
- https://github.com/shopperlabs/shopper/releases/tag/v2.8.1 x_refsource_MISC