Vulnerability · Published Jul 28, 2026 · Assigned by GitHub_M

CVE-2026-56821Netty: Out-of-date OCSP Responses Accepted by OcspServerCertificateValidator

High 7.4

In plain English

A high-severity security flaw in netty from netty. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 12% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.4High
Exploit odds (30 days)0.2%top 87.5% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Netty is an asynchronous, event-driven network application framework. Prior to versions 4.1.136.Final and 4.2.16.Final, the OcspServerCertificateValidator flags an out-of-date OCSP response but does not stop processing it, so an expired GOOD response is still reported as VALID, letting an on-path attacker replay a stale GOOD response to bypass revocation of a since-revoked certificate. Exploitation can lead to certificate revocation bypass via replay of an expired OCSP response. Any application using OcspServerCertificateValidator is affected; a revoked certificate can be accepted. This issue has been fixed in versions 4.1.136.Final and 4.2.16.Final.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12nettyno fix listedDEBIAN-CVE-2026-56821
Debian:13nettyno fix listedDEBIAN-CVE-2026-56821
Debian:14nettyno fix listedDEBIAN-CVE-2026-56821
Mavenio.netty:netty-handler-ssl-ocsp4.2.16.FinalGHSA-g7hg-vrcf-mvmr
Mavenio.netty:netty-handler-ssl-ocsp4.1.136.FinalGHSA-g7hg-vrcf-mvmr
Ubuntu:26.10nettyno fix listedUBUNTU-CVE-2026-56821

Affected products (as reported)

VendorProductVersions
netty netty < 4.1.136.Final>= 4.2.0.Final, < 4.2.16.Final

Weakness: CWE-299 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

References