Vulnerability · Published Jul 8, 2026 · Assigned by GitHub_M
CVE-2026-56669Elysia: Inefficient Algorithmic Complexity and Interpretation Conflict
High 7.5
In plain English
A high-severity security flaw in elysia from elysiajs. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 50% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Elysia is a Typescript framework for request validation, type inference, OpenAPI documentation, and client-server communication. Prior to 1.4.29, Elysia uses getAll in form data normalization for multipart/form-data endpoints, causing the amount of work to grow quadratically with the number of unique key-value pairs and allowing CPU exhaustion. This issue is fixed in version 1.4.29.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | elysia | 1.4.29 | GHSA-9643-4qgh-g8mx |
Affected products (as reported)
Weakness: CWE-407, CWE-436 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
References
- https://github.com/elysiajs/elysia/security/advisories/GHSA-9643-4qgh-g8mx x_refsource_CONFIRM
- https://github.com/elysiajs/elysia/commit/8358ff9efbcedf9534995f5977f26b9ceab59329 x_refsource_MISC
- https://gist.github.com/jviide/ea040eabe7bac058326174e2cd42dfd9 x_refsource_MISC
- https://github.com/elysiajs/elysia/releases/tag/1.4.29 x_refsource_MISC