Vulnerability · Published Oct 1, 2026 · Assigned by GitHub_M
CVE-2026-56662GetSimple CMS: Missing CSRF protection in UpdateCE allows forging a privileged server-side update request
Critical 9.6
In plain English
A critical-severity cross-site request forgery in GetSimpleCMS-CE from GetSimpleCMS-CE. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities).
Official description
GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the UpdateCE update form contained no anti-CSRF token, and the POST handler performed no token or request-origin verification. A remote attacker can host a page that auto-submits a forged POST to the update endpoint; when an authenticated administrator visits it, the server performs an attacker-directed download-and-deploy operation in the administrator's session — with no further interaction. Because the deployed content is executed (see the related ZIP-extraction advisory), this yields remote code execution. The url field is additionally written into the form unescaped, providing a secondary HTML-injection sink via a malicious upgrade.json. This issue has been patched in version 1.5.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GetSimpleCMS-CE | GetSimpleCMS-CE | < 1.5 |
Weakness: CWE-352 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H