Vulnerability · Published Oct 1, 2026 · Assigned by GitHub_M
CVE-2026-56661GetSimple CMS: Server-Side Request Forgery in the UpdateCE update endpoint
High 7.5
In plain English
A high-severity server-side request forgery in GetSimpleCMS-CE from GetSimpleCMS-CE. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 18% of all known vulnerabilities).
Official description
GetSimple CMS is a content management system (CMS), and GetSimple CMS CE is the community edition of that CMS. Prior to version 1.5, the update handler fetches a user-supplied URL with file_get_contents() after only format validation (FILTER_VALIDATE_URL) — there is no validation of the request destination. An attacker who can submit the form can make the server issue requests to arbitrary destinations, including internal-only services and cloud metadata endpoints (169.254.169.254). The fetched response body is written to a web-accessible file (/Tmpfile.zip) and is not deleted when the content is not a valid ZIP, turning this into a full-read SSRF: the attacker can retrieve the response of the internal request directly. This issue has been patched in version 1.5.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| GetSimpleCMS-CE | GetSimpleCMS-CE | < 1.5 |
Weakness: CWE-918 · Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:L