Vulnerability · Published Jun 30, 2026 · Assigned by VulnCheck
CVE-2026-56356n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field
Medium 5.4
In plain English
A medium-severity cross-site scripting in n8n from n8n. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n contains a stored cross-site scripting vulnerability in the Chat Trigger node's Custom CSS field due to a misconfiguration of the sanitize-html library. Affected releases are those before 1.123.27, the 2.0.0 through 2.13.2 line, and 2.14.0 (fixed in 1.123.27, 2.13.3, and 2.14.1). An authenticated user with permission to create or modify workflows can inject JavaScript that bypasses sanitization, resulting in stored XSS against any user who visits the public chat page.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.27 | GHSA-3c7f-5hgj-h279 |
| npm | n8n | 2.14.1 | GHSA-3c7f-5hgj-h279 |
| npm | n8n | 2.13.3 | GHSA-3c7f-5hgj-h279 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
References
- GitHub Security Advisory (GHSA-3c7f-5hgj-h279) vendor-advisory
- VulnCheck Advisory: n8n - Stored Cross-Site Scripting in Chat Trigger Node Custom CSS Field third-party-advisory