Vulnerability · Published Jun 25, 2026 · Assigned by apache
CVE-2026-56130Apache Shiro: Remember-me cookie isn't checked for expiry on the server
Low 2.0
In plain English
A low-severity security flaw in Apache Shiro from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 23% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
"Remember me" cookie age is not verified on the server. This potentially allows an attacker to intercept a valid cookie and reuse it indefinitely, even after the configured expiration time has passed. This issue affects all Apache Shiro versions from 1.2.4 through 2.x, and 3.0.0-alpha-1, only when RememberMe functionality is enabled. Upgrade to version 3.0.0 or later, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | shiro | no fix listed | DEBIAN-CVE-2026-56130 |
| Debian:13 | shiro | no fix listed | DEBIAN-CVE-2026-56130 |
| Debian:14 | shiro | no fix listed | DEBIAN-CVE-2026-56130 |
| Maven | org.apache.shiro:shiro-core | 3.0.0 | GHSA-m8g6-vrr2-x7ff |
| Maven | org.apache.shiro:shiro-web | 3.0.0 | GHSA-m8g6-vrr2-x7ff |
| Ubuntu:22.04:LTS | shiro | no fix listed | UBUNTU-CVE-2026-56130 |
| Ubuntu:25.10 | shiro | no fix listed | UBUNTU-CVE-2026-56130 |
| Ubuntu:26.04:LTS | shiro | no fix listed | UBUNTU-CVE-2026-56130 |
| Ubuntu:26.10 | shiro | no fix listed | UBUNTU-CVE-2026-56130 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Shiro | 1.2.4 – through 2.99.993.0.0-alpha-0 – through 3.0.0-alpha-1 |
Weakness: CWE-294 · Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/S:N/AU:Y/V:D/RE:L/U:Green