Vulnerability · Published Jul 27, 2026 · Assigned by apache
CVE-2026-55970Apache Thrift: C++ heap out-of-bounds read in THeaderTransport::readHeaderFormat()
Medium 6.9
In plain English
A medium-severity security flaw in Apache Thrift from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.8%top 44.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known
Official description
Buffer Over-read vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | thrift | no fix listed | DEBIAN-CVE-2026-55970 |
| Debian:13 | thrift | no fix listed | DEBIAN-CVE-2026-55970 |
| Debian:14 | thrift | 0.24.0-2 | DEBIAN-CVE-2026-55970 |
| Ubuntu:22.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-55970 |
| Ubuntu:24.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-55970 |
| Ubuntu:26.04:LTS | thrift | no fix listed | UBUNTU-CVE-2026-55970 |
| Ubuntu:26.10 | thrift | no fix listed | UBUNTU-CVE-2026-55970 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Thrift | 0 – before 0.24.0 |
Weakness: CWE-126 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N