Vulnerability · Published Jun 29, 2026 · Assigned by apache
CVE-2026-55957Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind
High 7.3
In plain English
A high-severity security flaw in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 2.9% (higher than 87% of all known vulnerabilities). Ready-made attack tooling exists: public proof-of-concept code. Fixed versions are available - upgrade the affected package.
Official description
Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | tomcat | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-admin-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-docs-webapp | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-el-3.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-jsp-2.3-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-lib | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-servlet-4.0-api | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| AlmaLinux:8 | tomcat-webapps | 1:9.0.120-1.el8_10 | ALSA-2026:68677 |
| Debian:12 | tomcat10 | 10.1.52-1~deb12u1 | DEBIAN-CVE-2026-55957 |
| Debian:13 | tomcat10 | 10.1.52-1~deb13u1 | DEBIAN-CVE-2026-55957 |
| Debian:14 | tomcat10 | 10.1.40-1 | DEBIAN-CVE-2026-55957 |
| Debian:13 | tomcat11 | 11.0.15-1~deb13u1 | DEBIAN-CVE-2026-55957 |
| Debian:14 | tomcat11 | 11.0.5-1 | DEBIAN-CVE-2026-55957 |
| Debian:12 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-55957 |
| Debian:13 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-55957 |
| Debian:14 | tomcat9 | 9.0.70-2 | DEBIAN-CVE-2026-55957 |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 10.1.37 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 9.0.101 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat.embed:tomcat-embed-core | 11.0.5 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat | 11.0.5 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat | 9.0.101 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat | 10.1.37 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat-catalina | 11.0.5 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat-catalina | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat-catalina | no fix listed | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat-catalina | 9.0.101 | GHSA-7895-gffq-w6jq |
| Maven | org.apache.tomcat:tomcat-catalina | 10.1.37 | GHSA-7895-gffq-w6jq |
| Rocky Linux:8 | tomcat | 1:9.0.120-1.el8_10 | RLSA-2026:68677 |
| Ubuntu:24.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:25.10 | tomcat10 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.04:LTS | tomcat10 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.10 | tomcat10 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:25.10 | tomcat11 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.04:LTS | tomcat11 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.10 | tomcat11 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:24.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:25.10 | tomcat9 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.04:LTS | tomcat9 | no fix listed | UBUNTU-CVE-2026-55957 |
| Ubuntu:26.10 | tomcat9 | no fix listed | UBUNTU-CVE-2026-55957 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| Apache Software Foundation | Apache Tomcat | 11.0.0-M1 – through 11.0.410.1.0-M1 – through 10.1.369.0.0.M1 – through 9.0.1008.5.0 – through 8.5.1007.0.0 – through 7.0.109 |
Weakness: CWE-304 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L