Vulnerability · Published Jun 29, 2026 · Assigned by apache

CVE-2026-55955Apache Tomcat: EncryptInterceptor not protected against replay attacks

Medium 6.5

In plain English

A medium-severity improper authentication in Apache Tomcat from Apache Software Foundation. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 61.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
AlmaLinux:8tomcat1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-admin-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-admin-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-docs-webapp1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-docs-webapp1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-el-3.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-el-3.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-jsp-2.3-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-jsp-2.3-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-lib1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-lib1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-servlet-4.0-api1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-servlet-4.0-api1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:8tomcat-webapps1:9.0.120-1.el8_10ALSA-2026:68677
AlmaLinux:9tomcat-webapps1:9.0.120-2.el9_8ALSA-2026:68660
AlmaLinux:10tomcat91:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-admin-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-docs-webapp1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-el-3.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-jsp-2.3-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-lib1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-servlet-4.0-api1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
AlmaLinux:10tomcat9-webapps1:9.0.120-1.el10_2.alma.1ALSA-2026:68651
Debian:12tomcat10no fix listedDEBIAN-CVE-2026-55955
Debian:13tomcat10no fix listedDEBIAN-CVE-2026-55955
Debian:14tomcat1010.1.60-1DEBIAN-CVE-2026-55955
Debian:13tomcat11no fix listedDEBIAN-CVE-2026-55955
Debian:14tomcat1111.0.24-1DEBIAN-CVE-2026-55955
Debian:12tomcat99.0.70-2DEBIAN-CVE-2026-55955
Debian:13tomcat99.0.70-2DEBIAN-CVE-2026-55955
Debian:14tomcat99.0.70-2DEBIAN-CVE-2026-55955
Mavenorg.apache.tomcat:tomcat9.0.119GHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcatno fix listedGHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcatno fix listedGHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat11.0.23GHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat10.1.56GHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat-tribes10.1.56GHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat-tribesno fix listedGHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat-tribesno fix listedGHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat-tribes11.0.23GHSA-c5ph-rghf-fjfj
Mavenorg.apache.tomcat:tomcat-tribes9.0.119GHSA-c5ph-rghf-fjfj
Ubuntu:24.04:LTStomcat10no fix listedUBUNTU-CVE-2026-55955
Ubuntu:25.10tomcat10no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.04:LTStomcat10no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.10tomcat10no fix listedUBUNTU-CVE-2026-55955
Ubuntu:25.10tomcat11no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.04:LTStomcat11no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.10tomcat11no fix listedUBUNTU-CVE-2026-55955
Ubuntu:24.04:LTStomcat9no fix listedUBUNTU-CVE-2026-55955
Ubuntu:25.10tomcat9no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.04:LTStomcat9no fix listedUBUNTU-CVE-2026-55955
Ubuntu:26.10tomcat9no fix listedUBUNTU-CVE-2026-55955

Affected products (as reported)

VendorProductVersions
Apache Software Foundation Apache Tomcat 11.0.0-M1 – through 11.0.2210.1.0-M1 – through 10.1.559.0.13 – through 9.0.1188.5.38 – through 8.5.1007.0.100 – through 7.0.109

Weakness: CWE-287 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

References