Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-55895Vim: Vimscript Code Injection in netrw NetrwLocalRmFile() via crafted filename
Medium 5.7
In plain English
A medium-severity OS command injection in vim from vim. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 13% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Vim is an open source, command line text editor. Prior to 9.2.0663, a Vimscript code injection vulnerability exists in s:NetrwLocalRmFile() in the netrw plugin (runtime/pack/dist/opt/netrw/autoload/netrw.vim) when deleting a local file from the browser. A filename derived from the buffer's directory listing is interpolated into an Ex command line passed to :execute with only the backslash character escaped, allowing a crafted filename containing a bar (|) to terminate the intended command and execute arbitrary Vimscript, including shell commands via :call system() and :!. This vulnerability is fixed in 9.2.0663.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Alpine:v3.23 | vim | 9.2.0854-r0 | ALPINE-CVE-2026-55895 |
| Alpine:v3.24 | vim | 9.2.0663-r0 | ALPINE-CVE-2026-55895 |
| Debian:12 | vim | no fix listed | DEBIAN-CVE-2026-55895 |
| Debian:13 | vim | 2:9.1.1230-2+deb13u1 | DEBIAN-CVE-2026-55895 |
| Debian:14 | vim | 2:9.2.0782-1 | DEBIAN-CVE-2026-55895 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.33 | UBUNTU-CVE-2026-55895 |
| Ubuntu:22.04:LTS | vim | 2:8.2.3995-1ubuntu2.33 | USN-8500-1 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.17 | USN-8500-1 |
| Ubuntu:24.04:LTS | vim | 2:9.1.0016-1ubuntu7.17 | UBUNTU-CVE-2026-55895 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.8 | USN-8500-1 |
| Ubuntu:25.10 | vim | 2:9.1.0967-1ubuntu6.8 | UBUNTU-CVE-2026-55895 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.6 | USN-8500-1 |
| Ubuntu:26.04:LTS | vim | 2:9.1.2141-1ubuntu4.6 | UBUNTU-CVE-2026-55895 |
Affected products (as reported)
Weakness: CWE-78, CWE-94 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U
References
- https://github.com/vim/vim/security/advisories/GHSA-vhh8-v6wx-hjjh x_refsource_CONFIRM
- https://github.com/vim/vim/commit/55bc757a5d436e59d50fe43f7cda94b118f86cb2 x_refsource_MISC
- https://github.com/vim/vim/releases/tag/v9.2.0663 x_refsource_MISC