Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M
CVE-2026-55843Snipe-IT: Improper Privilege Management
High 7.0
In plain English
A high-severity privilege mismanagement in snipe-it from grokability. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.6.0, UsersController::update() passes a missing permission request field through NormalizePermissionsPayloadAction and PreserveUnauthorizedPrivilegedPermissionsAction in a way that can overwrite a target user’s permissions with a sparse result, allowing an administrator updating another administrator, or a user with users.edit updating a regular account, to remove the target’s administrative or granular permissions. This issue is fixed in version 8.6.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | snipe/snipe-it | 8.6.0 | GHSA-j5g3-42wp-gqm3 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grokability | snipe-it | < 8.6.0 |
Weakness: CWE-269 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N