Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M
CVE-2026-55766guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization
Medium 4.8
In plain English
A medium-severity security flaw in psr7 from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.1, guzzlehttp/psr7 did not reject CR/LF characters in certain first-party HTTP start-line fields: the request method, protocol version, and response reason phrase. If an application placed attacker-controlled data into one of those fields and later serialized the PSR-7 message as raw HTTP/1.x, for example with Message::toString() or an equivalent serializer, the serialized message could contain attacker-controlled header lines. The issue can also be reached through Message::parseRequest() or Message::parseResponse() when malformed raw messages are parsed into first-party PSR-7 objects and then serialized again. Creating or modifying a Request, Response, or other PSR-7 object alone is not sufficient. The issue requires the malformed message to be serialized and written to the network, forwarded, replayed, or otherwise processed by software that does not independently reject the malformed start line. This vulnerability is fixed in 2.12.1.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | php-guzzlehttp-psr7 | no fix listed | DEBIAN-CVE-2026-55766 |
| Debian:13 | php-guzzlehttp-psr7 | 2.7.1-1+deb13u2 | DEBIAN-CVE-2026-55766 |
| Debian:14 | php-guzzlehttp-psr7 | 2.12.1-1 | DEBIAN-CVE-2026-55766 |
| Packagist | guzzlehttp/psr7 | 2.12.1 | GHSA-vm85-hxw5-5432 |
| Ubuntu:24.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-55766 |
| Ubuntu:25.10 | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-55766 |
| Ubuntu:26.04:LTS | php-guzzlehttp-psr7 | no fix listed | UBUNTU-CVE-2026-55766 |
Affected products (as reported)
Weakness: CWE-93, CWE-113 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
References
- https://github.com/guzzle/psr7/security/advisories/GHSA-vm85-hxw5-5432 x_refsource_CONFIRM