Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-55698pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes
High 8.8
In plain English
A high-severity insufficient verification of data authenticity in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can persist package-manager bootstrap metadata in the first YAML document of pnpm-lock.yaml. Before the patch, direct pnpm execution trusted an already resolved packageManagerDependencies entry when the committed env lockfile contained matching pnpm and @pnpm/exe versions. A malicious repository could therefore commit package-manager lockfile package records and snapshots that bypassed fresh package-manager resolution, then cause pnpm to install and execute bytes selected by that committed lockfile state during automatic version switching. This vulnerability is fixed in 10.34.2 and 11.5.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.34.2 | GHSA-w466-c33r-3gjp |
| npm | pnpm | 11.5.3 | GHSA-w466-c33r-3gjp |
Affected products (as reported)
Weakness: CWE-345, CWE-494, CWE-829 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-w466-c33r-3gjp x_refsource_CONFIRM