Vulnerability · Published Jun 25, 2026 · Assigned by GitHub_M
CVE-2026-55697pnpm: Repository-controlled configDependencies can select a pacquet native install engine
High 7.5
In plain English
A high-severity OS command injection in pnpm from pnpm. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 9% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pnpm is a package manager. Prior to 10.34.2 and 11.5.3, pnpm can install configDependencies declared in pnpm-workspace.yaml before command dispatch. Before the patch, a repository could declare pacquet or @pnpm/pacquet as a config dependency and pnpm treated that repository-controlled dependency as an install-engine opt-in. During install, pnpm resolved a platform-specific @pacquet/<platform>-<arch>/pacquet binary from node_modules/.pnpm-config/<packageName> and spawned it as the developer or CI user. This vulnerability is fixed in 10.34.2 and 11.5.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | pnpm | 10.34.2 | GHSA-gj8w-mvpf-x27x |
| npm | pnpm | 11.5.3 | GHSA-gj8w-mvpf-x27x |
Affected products (as reported)
Weakness: CWE-78, CWE-494, CWE-829 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
References
- https://github.com/pnpm/pnpm/security/advisories/GHSA-gj8w-mvpf-x27x x_refsource_CONFIRM