Vulnerability · Published Jul 16, 2026 · Assigned by GitHub_M
CVE-2026-55629Whistle: Path traversal
High 8.7
In plain English
A high-severity path traversal in whistle from avwo. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.6% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Whistle is an HTTP, HTTP2, HTTPS, and WebSocket debugging proxy. Prior to 2.10.3, lib/service/service.js handles GET /cgi-bin/temp/get by reading req.query.filename, joining it to TEMP_FILES_PATH only when it matches the temporary file pattern, and otherwise passing the user-supplied filename directly to getFile, allowing a remote attacker to read arbitrary files such as /etc/passwd. This issue is reported as fixed in version 2.10.3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | whistle | 2.10.3 | GHSA-3vfr-4gwf-qxfp |
Affected products (as reported)
Weakness: CWE-22 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/avwo/whistle/security/advisories/GHSA-3vfr-4gwf-qxfp x_refsource_CONFIRM
- https://github.com/avwo/whistle/commit/777bcf69bae2972aa7138a158c91619185653cf5 x_refsource_MISC
- http://github.com/avwo/whistle/releases/tag/v2.10.3 x_refsource_MISC