Vulnerability · Published Aug 25, 2026 · Assigned by GitHub_M
CVE-2026-55585QWED: Authenticated Remote Code Execution via Unsafe SymPy `parse_expr()`
High 8.8
In plain English
A high-severity code injection in qwed-verification from QWED-AI. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 56% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
QWED is open-source AI verification infrastructure for deterministic verification of LLM outputs, tool calls, code, schemas, and agent state before production execution. Prior to 5.1.2, the qwed package passes caller-controlled math expressions directly to SymPy parse_expr() without restricted global_dict and local_dict namespaces, allowing Python eval() to resolve builtins and execute arbitrary Python code in the API server process. In src/qwed_new/api/main.py, POST /verify/math is protected by get_current_tenant but accepts any valid tenant API key, reads the expression field, applies only a cosmetic re.sub(r'(\d)(()', r'\1*\2', expression) normalization, and passes the result to parse_expr(). In src/qwed_new/core/batch.py, POST /verify/batch sends math items through batch_service.create_job(), stores item.query verbatim, and _verify_item() passes VerificationType.MATH input to parse_expr() without sanitization. The default-enabled POST /auth/signup endpoint allows anyone to create a standard tenant account, POST /auth/api-keys issues an x-api-key, and either vulnerable path can then be used to read or write files, modify data, execute operating system commands, terminate the service, and compromise other tenants in a shared deployment. This issue is fixed in version 5.1.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | qwed | 5.1.2 | GHSA-q27q-98j4-9pfv |
| PyPI | qwed | 5.1.2 | PYSEC-2026-3914 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| QWED-AI | qwed-verification | < 5.1.2 |
Weakness: CWE-94 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
References
- https://github.com/QWED-AI/qwed-verification/security/advisories/GHSA-q27q-98j4-9pfv x_refsource_CONFIRM
- https://github.com/QWED-AI/qwed-verification/pull/200 x_refsource_MISC
- https://github.com/QWED-AI/qwed-verification/commit/6066b68c0c4f4cc2c3771824822aaa864d082ef8 x_refsource_MISC
- https://github.com/QWED-AI/qwed-verification/commit/dc9d4db72ca4b4ae3f96d0e6a0c27a9e38a06f61 x_refsource_MISC