Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-55568Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext

Medium 5.9

In plain English

A medium-severity security flaw in guzzle from guzzle. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.1% (higher than 4% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)5.9Medium
Exploit odds (30 days)0.1%top 96.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12guzzleno fix listedDEBIAN-CVE-2026-55568
Debian:13guzzleno fix listedDEBIAN-CVE-2026-55568
Debian:14guzzle7.12.1-1DEBIAN-CVE-2026-55568
Packagistguzzlehttp/guzzle7.12.1GHSA-wpwq-4j6v-78m3
Ubuntu:24.04:LTSguzzleno fix listedUBUNTU-CVE-2026-55568
Ubuntu:25.10guzzleno fix listedUBUNTU-CVE-2026-55568
Ubuntu:26.04:LTSguzzleno fix listedUBUNTU-CVE-2026-55568
Ubuntu:26.10guzzleno fix listedUBUNTU-CVE-2026-55568

Affected products (as reported)

VendorProductVersions
guzzle guzzle < 7.12.1

Weakness: CWE-311, CWE-319, CWE-636 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

References