Vulnerability · Published Aug 28, 2026 · Assigned by GitHub_M

CVE-2026-55521Yamcs : Multiple Missing Function Level Access Control vulnerabilities in Yamcs Core API

High 8.8

In plain English

A high-severity missing authorization in yamcs from yamcs. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 45% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.8High
Exploit odds (30 days)0.5%top 55.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Yamcs is a mission control framework. Prior to 5.12.8 and 5.13.2, Yamcs omits authorization checks in IndexesApi.listPacketIndex, IndexesApi.listEventIndex, Cop1Api.disable, Cop1Api.resume, Cop1Api.initialize, Cop1Api.updateConfig, and TimeApi.setTime. An authenticated low-privilege user can read packet and event index metadata without ObjectPrivilegeType.ReadPacket, alter COP-1 link state without SystemPrivilege.ControlLinks, and manipulate simulation time. These operations can disclose telemetry metadata, disrupt telecommand handling, and affect system integrity and availability. This issue is fixed in versions 5.12.8 and 5.13.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Mavenorg.yamcs:yamcs-core5.13.2GHSA-962x-ccwf-8x6p
Mavenorg.yamcs:yamcs-core5.12.8GHSA-962x-ccwf-8x6p

Affected products (as reported)

VendorProductVersions
yamcs yamcs < 5.12.8>= 5.13.0, < 5.13.2

Weakness: CWE-862 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References