Vulnerability · Published Jul 6, 2026 · Assigned by GitHub_M

CVE-2026-55514vLLM denial of service via prompt embeds on M-RoPE models

High 7.1

In plain English

A high-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.7% (higher than 52% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)7.1High
Exploit odds (30 days)0.7%top 48.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is a library for LLM inference and serving. From 0.12.0 to before 0.24.0, sending a pure prompt embeds payload in a /v1/completions request with a model using M-RoPE causes EngineCore to fail an assertion and fatally crash, shutting down the entire server application. Any remote user who is authorized to make a /v1/completions request can make such a request and induce a crash. This issue is fixed in version 0.24.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.24.0GHSA-33cg-gxv8-3p8g
PyPIvllm0.24.0PYSEC-2026-2303

Affected products (as reported)

VendorProductVersions
vllm-project vllm >= 0.12.0, < 0.24.0

Weakness: CWE-617 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

References