Vulnerability · Published Jul 10, 2026 · Assigned by GitHub_M
CVE-2026-55479Snipe-IT: Incorrect permission for legacy license checkin API
Medium 5.3
In plain English
A medium-severity incorrect authorization in snipe-it from grokability. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 26% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Snipe-IT is an IT asset/license management system. Prior to 8.6.2, the legacy single-seat license checkin flow authorizes the action with the checkout permission instead of the checkin permission, allowing a user who can assign licenses but not unassign them to directly access the old checkin endpoint and reclaim a license seat assigned to another user or asset. This issue is fixed in version 8.6.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Packagist | snipe/snipe-it | 8.6.2 | GHSA-8frh-vhgh-64cf |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| grokability | snipe-it | < 8.6.2 |
Weakness: CWE-863 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N