Vulnerability · Published Aug 24, 2026 · Assigned by GitHub_M

CVE-2026-55468Wagtail: Improper restriction handling on Pages admin API

Medium 4.3

In plain English

A medium-severity security flaw in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.3Medium
Exploit odds (30 days)0.3%top 72.1% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Wagtail is an open source content management system built on Django. Prior to versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2 on their respective release lines, the internal Pages admin API returns page fields declared in api_fields without sufficient access control, allowing a user with Wagtail admin access to retrieve restricted draft and live page content. This issue is fixed in versions 7.0.9, 7.3.4, 7.4.3, and 8.0rc2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIwagtail7.0.9GHSA-3vrh-m9w7-v94f
PyPIwagtail7.3.4GHSA-3vrh-m9w7-v94f
PyPIwagtail7.4.3GHSA-3vrh-m9w7-v94f
PyPIwagtail8.0rc2GHSA-3vrh-m9w7-v94f
PyPIwagtail7.0.9, 7.3.4, 7.4.3, 8.0rc2PYSEC-2026-3939

Affected products (as reported)

VendorProductVersions
wagtail wagtail < 7.0.9>= 7.1, < 7.3.4>= 7.4, < 7.4.3>= 8.0rc1, < 8.0rc2

Weakness: CWE-280 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

References