Vulnerability · Published Jul 7, 2026 · Assigned by GitHub_M
CVE-2026-55408Koodo Reader: Remote code execution via malicious epub file
High 8.4
In plain English
A high-severity code injection in koodo-reader from koodo-reader. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 16% of all known vulnerabilities).
Official description
Koodo Reader is an ebook reader. In version 2.3.0 and earlier, Koodo Reader is vulnerable to remote code execution through malicious EPUB files because the open-book IPC handler enables nodeIntegrationInSubFrames and EPUB chapter content is rendered with unsanitized innerHTML. An attacker can craft an EPUB book that, when imported and opened by the victim, instantiates a hidden iframe with Node.js API access and executes arbitrary operating system commands with the victim user's privileges. This issue is fixed in version 2.3.1.
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| koodo-reader | koodo-reader | < 2.3.1 |
Weakness: CWE-94 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N