Vulnerability · Published Aug 25, 2026 · Assigned by GitHub_M

CVE-2026-54757Trestle has Server-Side Template Injection (SSTI) via Recursive Template Re-evaluation of Untrusted Data

High 7.8

In plain English

A high-severity code injection in compliance-trestle from oscal-compass. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 30% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.8High
Exploit odds (30 days)0.4%top 69.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Compliance-trestle (Trestle) is a Python SDK and command-line tool for managing OSCAL compliance documents. In versions before 3.12.4 and versions 4.0.0 through 4.0.3, Trestle is vulnerable to server-side template injection that can lead to remote code execution. This occurs because the MDCleanInclude and MDSectionInclude Jinja2 tags re-parse untrusted Markdown content as template source code using a non-sandboxed jinja2.Environment. An attacker who controls content that Trestle renders, such as a crafted workspace Markdown file, a third-party SSP document, or a YAML lookup-table value, can inject a Jinja2 expression that traverses Python object internals to execute arbitrary operating system commands in the context of the Trestle process. This issue is fixed in versions 3.12.4 and 4.1.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIcompliance-trestle3.12.4GHSA-jw39-3688-r4rx
PyPIcompliance-trestle4.1.0GHSA-jw39-3688-r4rx
PyPIcompliance-trestle3.12.4, 4.1.0PYSEC-2026-3817

Affected products (as reported)

VendorProductVersions
oscal-compass compliance-trestle < 3.12.4>= 4.0.0, < 4.1.0

Weakness: CWE-94 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References