Vulnerability · Published Jul 31, 2026 · Assigned by GitHub_M

CVE-2026-54737@phun-ky/defaults-deep Has a Prototype Pollution issue via Unsafe Recursive Property Merging

High 7.3

In plain English

A high-severity prototype pollution in defaults-deep from phun-ky. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 40% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.5%top 60.4% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

@phun-ky/defaults-deep is a library like lodash defaultsDeep with array preservation and no lodash dependency. Prior to 2.0.5, defaultsDeep() recursively merges user-supplied objects without filtering proto, constructor, and prototype, allowing properties to be written to Object.prototype. This issue is fixed in version 2.0.5.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@phun-ky/defaults-deep2.0.5GHSA-mj3g-7xcc-x4vh

Affected products (as reported)

VendorProductVersions
phun-ky defaults-deep < 2.0.5

Weakness: CWE-1321 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

References