Vulnerability · Published Sep 14, 2026 · Assigned by GitHub_M
CVE-2026-54723devpi: Database contents leak
Medium 6.5
In plain English
A medium-severity security flaw in devpi from devpi. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
devpi is a Python package index staging server and packaging, testing, and release tool. Prior to 6.20.2 and 7.0.0b3, a server configured with the primary or deprecated master role allows an unauthenticated, modified GET request to the +changelog route because verify_primary does not reject a missing identity and therefore fails to require ReplicaIdentity. The response can disclose complete database content, including Argon2 password hashes and identifiers and salts for devpi-tokens; exposed hashes may be subject to dictionary attacks, and public tokens may assist attempts to derive the server secret. Large responses can also consume significant CPU, input/output capacity, and bandwidth. Servers using the standalone role are not exposed through replication, and an instance served exclusively through nginx with devpi-lockdown redirects the request to login with no known exploit. This issue is fixed in devpi-server versions 6.20.2 and 7.0.0b3.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | devpi-server | 6.20.2 | GHSA-m5pq-69xg-vcq3 |
| PyPI | devpi-server | 6.20.2 | PYSEC-2026-3661 |
Affected products (as reported)
Weakness: CWE-304 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
References
- https://github.com/devpi/devpi/security/advisories/GHSA-m5pq-69xg-vcq3 x_refsource_CONFIRM
- https://github.com/devpi/devpi/commit/b4ea49fed4a6233d63f8509c3bf7efafc9b2db17 x_refsource_MISC
- https://github.com/devpi/devpi/releases/tag/server-6.20.2 x_refsource_MISC