Vulnerability · Published Jul 29, 2026 · Assigned by GitHub_M

CVE-2026-54664swagger-typescript-api vulnerable to code injection via unescaped enum string values

High 8.3

In plain English

A high-severity injection in swagger-typescript-api from acacode. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 41% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.3High
Exploit odds (30 days)0.5%top 58.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

swagger-typescript-api generates API clients for Fetch or Axios from an OpenAPI Specification. Prior to 13.12.2, src/schema-parser/base-schema-parsers/enum.ts passes components.schemas.*.enum[i] values to Ts.StringValue in src/configuration.ts without escaping before templates/base/enum-data-contract.ejs renders TypeScript enum declarations, allowing an attacker-controlled OpenAPI spec to inject code that executes when the generated module is imported. This issue is fixed in version 13.12.2.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npmswagger-typescript-api13.12.2GHSA-5f94-x226-ccpm

Affected products (as reported)

VendorProductVersions
acacode swagger-typescript-api < 13.12.2

Weakness: CWE-74, CWE-94, CWE-1336 · Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

References