Vulnerability · Published Jul 28, 2026 · Assigned by GitHub_M

CVE-2026-54603OAuth2::Client#request: Protocol-relative redirect Location overrides authority, leaking bearer Authorization to attacker host

High 8.6

In plain English

A high-severity information exposure in oauth2 from ruby-oauth. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 39% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)8.6High
Exploit odds (30 days)0.4%top 60.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

OAuth2 is a Ruby wrapper for the OAuth 2.0 and 2.1 authorization frameworks, including OpenID Connect (OIDC). From 0.4.0 to 2.0.21, a protocol-relative redirect Location returned to OAuth2::Client#request overrides the request authority, so the bearer Authorization header is sent to an attacker-controlled host, leaking the credential. This issue is fixed in version 2.0.22.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-oauth21.4.4-1+deb12u1DEBIAN-CVE-2026-54603
Debian:13ruby-oauth2no fix listedDEBIAN-CVE-2026-54603
Debian:14ruby-oauth22.0.25-1DEBIAN-CVE-2026-54603
RubyGemsoauth22.0.22GHSA-pp92-crg2-gfv9
Ubuntu:22.04:LTSruby-oauth2no fix listedUBUNTU-CVE-2026-54603
Ubuntu:24.04:LTSruby-oauth2no fix listedUBUNTU-CVE-2026-54603
Ubuntu:26.04:LTSruby-oauth2no fix listedUBUNTU-CVE-2026-54603
Ubuntu:26.10ruby-oauth2no fix listedUBUNTU-CVE-2026-54603

Affected products (as reported)

VendorProductVersions
ruby-oauth oauth2 >= 0.4.0, < 2.0.22

Weakness: CWE-200, CWE-601 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

References