Vulnerability · Published Jul 7, 2026 · Assigned by GitHub_M

CVE-2026-54601FastGPT: reTrainingCollection allows server-owned datasetId override causing cross-tenant authorization confusion

Medium 6.3

In plain English

A medium-severity security flaw in FastGPT from labring. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 22% of all known vulnerabilities).

Severity (CVSS 3.1)6.3Medium
Exploit odds (30 days)0.3%top 77.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

FastGPT is an open source AI knowledge base platform. From 4.14.17 to before 4.15.0-beta4, FastGPT allows an authenticated tenant user to call POST /api/core/dataset/collection/create/reTrainingCollection in a way that persists a server-owned datasetId value from another tenant. This creates mixed dataset objects and downstream dataset, collection, and training endpoints then make authorization decisions from inconsistent ownership anchors, allowing cross-tenant read, update, and delete access when mixed object ids are known. This issue is fixed in version 4.15.0-beta4.

Affected products (as reported)

VendorProductVersions
labring FastGPT >= 4.14.17, < 4.15.0-beta4

Weakness: CWE-915 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

References