Vulnerability · Published Sep 14, 2026 · Assigned by GitHub_M

CVE-2026-54559PocketSphinx: Buffer overflows in language and acoustic model loading code

Medium 6.9

In plain English

A medium-severity memory corruption in pocketsphinx from cmusphinx. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 46% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)6.9Medium
Exploit odds (30 days)0.5%top 53.9% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIpocketsphinx5.1.1GHSA-56r5-2p2f-7cxp
PyPIpocketsphinx5.1.1PYSEC-2026-3498
Ubuntu:22.04:LTSpocketsphinxno fix listedUBUNTU-CVE-2026-54559
Ubuntu:24.04:LTSpocketsphinxno fix listedUBUNTU-CVE-2026-54559
Ubuntu:26.04:LTSpocketsphinxno fix listedUBUNTU-CVE-2026-54559
Ubuntu:26.10pocketsphinxno fix listedUBUNTU-CVE-2026-54559

Affected products (as reported)

VendorProductVersions
cmusphinx pocketsphinx < 5.1.1

Weakness: CWE-119, CWE-121, CWE-122 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

References