Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-54328Pi: Predictable temporary extension install paths allow local privilege escalation on shared Linux hosts

High 7.3

In plain English

A high-severity security flaw in pi from earendil-works. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.3High
Exploit odds (30 days)0.2%top 94.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pi is a minimal terminal coding harness. From 0.74.0 until 0.78.1, Pi versions with temporary npm or git extension package installs used predictable paths under the operating system temporary directory. On Linux-based multi-user systems, a local attacker who can write to the shared temporary directory could prepare the expected package location before another user runs pi with a temporary extension package source. Pi could then load attacker-controlled extension code in the victim user's process. This vulnerability is fixed in 0.78.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@earendil-works/pi-coding-agent0.78.1GHSA-jfgx-wxx8-mp94
npm@mariozechner/pi-coding-agentno fix listedGHSA-jfgx-wxx8-mp94

Affected products (as reported)

VendorProductVersions
earendil-works pi >= 0.74.0, < 0.78.1

Weakness: CWE-379 · Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

References