Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M

CVE-2026-54325Pi loads project-local extensions without approval

Medium 4.4

In plain English

A medium-severity security flaw in pi from earendil-works. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 6% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)4.4Medium
Exploit odds (30 days)0.2%top 94.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Pi is a minimal terminal coding harness. Pi before 0.79.0 loaded project-local configuration and resources from a repository's .pi directory without first asking the user to trust that repository. This included project-local extensions, which are executable TypeScript or JavaScript modules loaded into the Pi process. An attacker who controls a repository could place Pi-specific project resources in that repository. If a user then started Pi from that working tree, the project-local extension code could run with the same privileges as the local Pi process without the user having a convenient way to make a trust decision. This vulnerability is fixed in 0.79.0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
npm@earendil-works/pi-coding-agent0.79.0GHSA-mqxh-6gq7-558m

Affected products (as reported)

VendorProductVersions
earendil-works pi < 0.79.0

Weakness: CWE-829 · Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

References