Vulnerability · Published Jun 23, 2026 · Assigned by GitHub_M
CVE-2026-54302n8n: Stored XSS in Chat Trigger Node
High 7.0
In plain English
A high-severity cross-site scripting in n8n from n8n-io. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 14% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, an authenticated user with workflow edit access could inject arbitrary JavaScript into the Chat Trigger's generated page by setting a malicious webhookId. When a logged-in user visited the chat URL, the injected code executed in the n8n origin with that user's session privileges. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| npm | n8n | 1.123.55 | GHSA-42h7-m79w-wvg5 |
| npm | n8n | 2.26.2 | GHSA-42h7-m79w-wvg5 |
| npm | n8n | 2.25.7 | GHSA-42h7-m79w-wvg5 |
Affected products (as reported)
Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-42h7-m79w-wvg5 x_refsource_CONFIRM