Vulnerability · Published Jun 24, 2026 · Assigned by GitHub_M

CVE-2026-54297Faraday: Uncontrolled recursion in NestedParamsEncoder allows stack exhaustion DoS via deeply nested query parameters

High 7.5

In plain English

A high-severity resource allocation without limits in faraday from lostisland. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.8% (higher than 55% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)7.5High
Exploit odds (30 days)0.8%top 44.6% of all CVEs
Exploited in the wildNo reportsCISA SSVC: poc
Attack toolingNoneno public tooling known

Official description

Faraday is an HTTP client library abstraction layer that provides a common interface over many adapters. From 1.0.0 until 1.10.6 and 2.14.3, Faraday::NestedParamsEncoder, the default nested query parameter encoder/decoder in Faraday, decodes nested query strings without enforcing a maximum nesting depth. A crafted query string causes Faraday to build a deeply nested Ruby Hash structure. The internal dehash routine then recursively walks this attacker-controlled structure without a depth limit. At sufficient depth, Ruby raises an uncaught SystemStackError (stack level too deep), crashing the calling thread or worker. This can lead to denial of service in applications that pass attacker-controlled query strings to Faraday's nested query parsing or URL-building paths. This vulnerability is fixed in 1.10.6 and 2.14.3.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12ruby-faradayno fix listedDEBIAN-CVE-2026-54297
Debian:13ruby-faradayno fix listedDEBIAN-CVE-2026-54297
Debian:14ruby-faraday2.14.3-1DEBIAN-CVE-2026-54297
RubyGemsfaraday2.14.3GHSA-98m9-hrrm-r99r
RubyGemsfaraday1.10.6GHSA-98m9-hrrm-r99r
Ubuntu:22.04:LTSruby-faradayno fix listedUBUNTU-CVE-2026-54297
Ubuntu:24.04:LTSruby-faradayno fix listedUBUNTU-CVE-2026-54297
Ubuntu:25.10ruby-faradayno fix listedUBUNTU-CVE-2026-54297
Ubuntu:26.04:LTSruby-faradayno fix listedUBUNTU-CVE-2026-54297

Affected products (as reported)

VendorProductVersions
lostisland faraday >= 1.0.0, < 1.10.6>= 2.0.0.alpha.pre.1, < 2.14.3

Weakness: CWE-674, CWE-770 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

References