Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-54265Angular: Two-Way Property Binding Sanitization Bypass (XSS)

Medium 5.3

In plain English

A medium-severity cross-site scripting in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 28% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)5.3Medium
Exploit odds (30 days)0.3%top 72.0% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an issue in the @angular/compiler package allows bypassing DOM property sanitization through the use of two-way property bindings. Specifically, when a native DOM property that requires sanitization (such as innerHTML, srcdoc, src, href, data, or sandbox) is bound using the two-way binding syntax (e.g., [(innerHTML)]="value" or bindon-innerHTML="value"), the Angular template compiler failed to apply the appropriate schema-derived sanitizer resolution to the TwoWayProperty operation. As a result, native two-way DOM bindings were emitted without the required sanitizer function, whereas equivalent one-way bindings would be properly sanitized. This flaw enables an attacker who can control the value of a two-way bound sensitive property to bypass Angular's built-in sanitization logic, potentially leading to client-side Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-54265
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-54265
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54265
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54265
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-54265
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54265
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-54265
npm@angular/compiler20.3.25GHSA-58w9-8g37-x9v5
npm@angular/compilerno fix listedGHSA-58w9-8g37-x9v5
npm@angular/compiler21.2.17GHSA-58w9-8g37-x9v5
npm@angular/compiler22.0.1GHSA-58w9-8g37-x9v5

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0 < 22.0.1>= 21.0.0-next.0 < 21.2.17>= 20.0.0-next.0 < 20.3.25<= 19.2.25

Weakness: CWE-79 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

References