Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-54264Angular: Sensitive Header Leakage on Cross-Origin Redirects in Angular Service Worker

High 8.3

In plain English

A high-severity information exposure in angular from angular. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 33% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 4.0)8.3High
Exploit odds (30 days)0.4%top 66.7% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.1, 21.2.17, and 20.3.25, an information disclosure vulnerability exists in the @angular/service-worker package of the Angular framework. When the Service Worker fetches assets, it preserves metadata (such as headers) from the original request. However, on cross-origin redirects, the Service Worker fails to strip sensitive headers, violating the Fetch redirect algorithm. This allows a remote attacker to obtain sensitive credentials (e.g., Authorization tokens, Proxy-Authorization credentials, or session cookies) by triggering a cross-origin redirect to an untrusted external origin. This vulnerability is fixed in 22.0.1, 21.2.17, and 20.3.25.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Debian:12angular.jsno fix listedDEBIAN-CVE-2026-54264
Debian:13angular.jsno fix listedDEBIAN-CVE-2026-54264
Ubuntu:22.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54264
Ubuntu:24.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54264
Ubuntu:25.10angular.jsno fix listedUBUNTU-CVE-2026-54264
Ubuntu:26.04:LTSangular.jsno fix listedUBUNTU-CVE-2026-54264
Ubuntu:26.10angular.jsno fix listedUBUNTU-CVE-2026-54264
npm@angular/service-worker20.3.25GHSA-qxh6-94w6-9r5p
npm@angular/service-workerno fix listedGHSA-qxh6-94w6-9r5p
npm@angular/service-worker21.2.17GHSA-qxh6-94w6-9r5p
npm@angular/service-worker22.0.1GHSA-qxh6-94w6-9r5p

Affected products (as reported)

VendorProductVersions
angular angular >= 22.0.0-next.0 < 22.0.1>= 21.0.0-next.0 < 21.2.17>= 20.0.0-next.0 < 20.3.25<= 19.2.25

Weakness: CWE-200, CWE-359 · Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N

References