Vulnerability · Published Jul 1, 2026 · Assigned by GitHub_M
CVE-2026-54260Wagtail: Denial of service via unbounded filter specs in the image preview
Medium 4.3
In plain English
A medium-severity uncontrolled resource consumption in wagtail from wagtail. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 31% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Wagtail is an open source content management system built on Django. In versions prior to 7.0.8, 7.3.3 and 7.4.2, an authenticated admin user can trigger expensive rendition processing with purposefully crafted filter specs resulting in potentially service degradation. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. This issue has been fixed in versions 7.0.8, 7.3.3, and 7.4.2.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | wagtail | 7.0.8 | GHSA-f2p5-j6fg-5cxf |
| PyPI | wagtail | 7.3.3 | GHSA-f2p5-j6fg-5cxf |
| PyPI | wagtail | 7.4.2 | GHSA-f2p5-j6fg-5cxf |
| PyPI | wagtail | 7.0.8, 7.3.3, 7.4.2 | PYSEC-2026-613 |
Affected products (as reported)
Weakness: CWE-400 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
References
- https://github.com/wagtail/wagtail/security/advisories/GHSA-f2p5-j6fg-5cxf x_refsource_CONFIRM