Vulnerability · Published Jun 22, 2026 · Assigned by GitHub_M

CVE-2026-54233vLLM: OOM Denial of Service via Audio Decompression Bomb

Medium 6.5

In plain English

A medium-severity security flaw in vllm from vllm-project. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)6.5Medium
Exploit odds (30 days)0.4%top 63.3% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

vLLM is an inference and serving engine for large language models (LLMs). Prior to 0.23.1rc0, vLLM's /v1/audio/transcriptions endpoint limits compressed upload size but not decoded PCM output. A 25MB OPUS file expands to ~14.9GB of float32 PCM at decode time. This vulnerability is fixed in 0.23.1rc0.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
PyPIvllm0.24.0GHSA-6pr9-rp53-2pmc
PyPIvllmno fix listedPYSEC-2026-3404

Affected products (as reported)

VendorProductVersions
vllm-project vllm < 0.23.1rc0

Weakness: CWE-409 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References