Vulnerability · Published Jul 17, 2026 · Assigned by GitHub_M
CVE-2026-54171Excon: redact additional sensitive/risky headers when following redirects
Medium 6.5
In plain English
A medium-severity security flaw in excon from excon. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 37% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Excon is usable, fast, simple HTTP 1.1 for Ruby. Prior to 1.5.0, Excon's RedirectFollower middleware failed to strip additional sensitive headers when following redirects and did not provide a custom list of headers to strip. This could cause inadvertent leakage of sensitive data when the initial request includes header information that is not intended for the new target. This issue is fixed in version 1.5.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Debian:12 | ruby-excon | no fix listed | DEBIAN-CVE-2026-54171 |
| Debian:13 | ruby-excon | no fix listed | DEBIAN-CVE-2026-54171 |
| Debian:14 | ruby-excon | 1.5.0-1 | DEBIAN-CVE-2026-54171 |
| RubyGems | excon | 1.5.0 | GHSA-48rx-c7pg-q66r |
| Ubuntu:22.04:LTS | ruby-excon | no fix listed | UBUNTU-CVE-2026-54171 |
| Ubuntu:24.04:LTS | ruby-excon | no fix listed | UBUNTU-CVE-2026-54171 |
| Ubuntu:26.04:LTS | ruby-excon | no fix listed | UBUNTU-CVE-2026-54171 |
| Ubuntu:26.10 | ruby-excon | no fix listed | UBUNTU-CVE-2026-54171 |
Affected products (as reported)
Weakness: CWE-201 · Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
References
- https://github.com/excon/excon/security/advisories/GHSA-48rx-c7pg-q66r x_refsource_CONFIRM
- https://github.com/excon/excon/pull/901 x_refsource_MISC
- https://github.com/excon/excon/commit/ea89a35308a12f4b791b6c50f2cbd33f94889fa3 x_refsource_MISC