Vulnerability · Published Jul 14, 2026 · Assigned by GitHub_M
CVE-2026-54058Pillow: Out-of-bounds read via attacker-controlled row stride on Pillow's mmap path (McIdas AREA files)
High 8.3
In plain English
A high-severity out-of-bounds read in Pillow from python-pillow. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.5% (higher than 44% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
Pillow is a Python imaging library. Prior to 12.3.0, when Pillow loads an uncompressed McIdas AREA image from a filename through the mmap raw codec path, attacker-controlled header words can set a row stride smaller than the natural row width, causing pixel access such as Image.tobytes(), getpixel, convert, or save to read beyond the mapped region and disclose adjacent process memory or fault. This issue is fixed in version 12.3.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| AlmaLinux:8 | python3-pillow | 5.1.1-23.el8_10 | ALSA-2026:48021 |
| AlmaLinux:8 | python3-pillow-devel | 5.1.1-23.el8_10 | ALSA-2026:48021 |
| AlmaLinux:8 | python3-pillow-doc | 5.1.1-23.el8_10 | ALSA-2026:48021 |
| AlmaLinux:8 | python3-pillow-tk | 5.1.1-23.el8_10 | ALSA-2026:48021 |
| Debian:12 | pillow | no fix listed | DEBIAN-CVE-2026-54058 |
| Debian:13 | pillow | no fix listed | DEBIAN-CVE-2026-54058 |
| Debian:14 | pillow | 12.3.0-1 | DEBIAN-CVE-2026-54058 |
| PyPI | pillow | 12.3.0 | GHSA-62p4-gmf7-7g93 |
| PyPI | pillow | 12.3.0 | PYSEC-2026-3493 |
| Rocky Linux:8 | python-pillow | 0:5.1.1-23.el8_10 | RLSA-2026:48021 |
| Ubuntu:22.04:LTS | pillow | 9.0.1-1ubuntu0.6 | USN-8999-1 |
| Ubuntu:22.04:LTS | pillow | 9.0.1-1ubuntu0.6 | UBUNTU-CVE-2026-54058 |
| Ubuntu:24.04:LTS | pillow | 10.2.0-1ubuntu1.4 | USN-8999-1 |
| Ubuntu:24.04:LTS | pillow | 10.2.0-1ubuntu1.4 | UBUNTU-CVE-2026-54058 |
| Ubuntu:26.04:LTS | pillow | 12.1.1-2ubuntu1.4 | USN-8999-1 |
| Ubuntu:26.04:LTS | pillow | 12.1.1-2ubuntu1.4 | UBUNTU-CVE-2026-54058 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| python-pillow | Pillow | < 12.3.0 |
Weakness: CWE-125 · Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:H/SC:N/SI:N/SA:N
References
- https://github.com/python-pillow/Pillow/security/advisories/GHSA-62p4-gmf7-7g93 x_refsource_CONFIRM
- https://github.com/python-pillow/Pillow/pull/9719 x_refsource_MISC
- https://github.com/python-pillow/Pillow/commit/6a8de891fb00968e5ea79bfa84368ed90b3cfc1d x_refsource_MISC
- https://github.com/python-pillow/Pillow/releases/tag/12.3.0 x_refsource_MISC