Vulnerability · Published Oct 1, 2026 · Assigned by GitHub_M
CVE-2026-54049Sakai Conversations has a Stored XSS Issue
High 8.7
In plain English
A high-severity cross-site scripting in sakai from sakaiproject. Proof-of-concept exploit code is public. The chance it is exploited in the next 30 days is estimated at 0.3% (higher than 25% of all known vulnerabilities).
Official description
Sakai is a Collaboration and Learning Environment (CLE). From versions 23.0 to before 23.5, and versions 25.0 to before 25.3, the Sakai Conversations tool stores topic and post messages without HTML sanitization, and the frontend renders them using LitElement's unsafeHTML() directive, resulting in stored cross-site scripting (XSS). Any authenticated user with access to a site that has the Conversations tool enabled can inject arbitrary HTML and JavaScript that executes in the browsers of all other users who view that topic or post. This issue has been patched in versions 23.5, 25.3, and 26.0.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| Maven | org.sakaiproject.conversations:sakai-conversations-impl | no fix listed | GHSA-w2x5-gv52-9ccv |
| Maven | org.sakaiproject.kernel:sakai-kernel-impl | no fix listed | GHSA-w2x5-gv52-9ccv |
| Maven | org.sakaiproject.rubrics:rubrics-impl | no fix listed | GHSA-w2x5-gv52-9ccv |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| sakaiproject | sakai | >= 23.0, < 23.5>= 25.0, < 25.3 |
Weakness: CWE-79 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N