Vulnerability · Published Sep 3, 2026 · Assigned by GitHub_M
CVE-2026-53720pymonocypher: Potential heap buffer overflow on nb_blocks in argon2i_32 when provided buffer is too small
Medium 5.1
In plain English
A medium-severity heap buffer overflow in pymonocypher from jetperch. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.2% (higher than 7% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.
Official description
pymonocypher uses cython to wrap the Monocypher C library. Prior to version 4.0.2.8, the argon2i_32 implementation does not check the nb_blocks size. If the caller does not provide a sufficiently large buffer based on the API contract, then argon2i_32 will write past the end of the buffer and possibly corrupt the heap. This issue has been patched in version 4.0.2.8.
Affected packages & fixed versions
| Ecosystem | Package | Fixed in | Advisory |
|---|---|---|---|
| PyPI | pymonocypher | 4.0.2.8 | GHSA-8f95-v3jq-cj86 |
| PyPI | pymonocypher | 4.0.2.8 | PYSEC-2026-3000 |
Affected products (as reported)
| Vendor | Product | Versions |
|---|---|---|
| jetperch | pymonocypher | < 4.0.2.8 |
Weakness: CWE-122, CWE-787, CWE-1284 · Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N