Vulnerability · Published Sep 14, 2026 · Assigned by GitHub_M

CVE-2026-53713Envoy Gateway: Authentication Bypass via Improper Input Validation in EnvoyExtensionPolicy Lua Allows Secret Disclosure

Critical 9.1

In plain English

A critical-severity improper input validation in gateway from envoyproxy. There are no confirmed reports of exploitation so far. The chance it is exploited in the next 30 days is estimated at 0.4% (higher than 38% of all known vulnerabilities). Fixed versions are available - upgrade the affected package.

Severity (CVSS 3.1)9.1Critical
Exploit odds (30 days)0.4%top 62.2% of all CVEs
Exploited in the wildNo reportsCISA SSVC: none
Attack toolingNoneno public tooling known

Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. Prior to 1.7.4 and 1.8.1, to_absolute_normalized_path in internal/gatewayapi/luavalidator/security.lua does not collapse redundant separators before is_critical_path evaluates Lua submitted through EnvoyExtensionPolicy during default Strict validation. Linux resolves a double-slash absolute path as the corresponding single-slash path, but the validator does not match the redundant-separator form, allowing submitted Lua to read arbitrary files from the gateway controller pod. Exposed files can include Kubernetes service-account tokens, TLS certificates, and process environment data, and the disclosed credentials can provide access to sensitive Kubernetes API Server or Gateway xDS server information. This issue is fixed in versions 1.7.4 and 1.8.1.

Affected packages & fixed versions

EcosystemPackageFixed inAdvisory
Gogithub.com/envoyproxy/gateway1.8.1GHSA-wcrf-9vrr-854f
Gogithub.com/envoyproxy/gateway1.7.4GHSA-wcrf-9vrr-854f
Gogithub.com/envoyproxy/gateway1.7.4, 1.8.1GO-2026-6011

Affected products (as reported)

VendorProductVersions
envoyproxy gateway < 1.7.4>= 1.8.0-rc.0, < 1.8.1

Weakness: CWE-20 · Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

References